SideBarMenu

< Fehler berichten | Entwicklungs-HOWTO | Orientierung im Verzeichnisbaum >

Auf dieser Seite... (ausblenden)

  1.   1.  Serverumgebung
    1.   1.1  Linux
    2.   1.2  Windows
    3.   1.3  Mac OS
    4.   1.4  Andere Betriebssysteme
  2.   2.  Aktuelle Version besorgen
  3.   3.  Installation und Konfiguration
  4.   4.  Entwicklungsumgebung
    1.   4.1  Einfacher Texteditor
    2.   4.2  Erweiterter Texteditor
    3.   4.3  ECLIPSE
  5.   5.  Änderungen einchecken

Um selbst mitzuentwickeln, brauchst du ein lokales Testsystem auf einem Rechner, für den du alle nötigen Rechte hast.

Das heißt im Einzelnen, dass du folgendes brauchst:

  • Ein Webserver (drigend empfohlen: Apache, aktuelle Version 2), vorzugsweise mit Schreibzugriff auf die zentralen Konfigurationsdateien
  • PHP ab Version 5
  • Schreibrechte im Dateisystem sowohl für Dateien, die für dne Webserver erreichbar sind, als auch für solche, die außerhalb liegen
  • Voller Zugriff auf eine MySQL-Datenbank (MySQL-Version 5 und aufwärts)
  • Einen SVN-Client zum Auschecken der aktuellsten Entwickler-Version von Stud.IP
  • Ein Editor oder eine Entwicklungsumgebung zum Bearbeiten von Dateien

1.  Serverumgebung

Um für Stud,IP zu entwickeln brauchst du Zugriff auf einen Webserver und dessen Dateisystem. Den kannst du auf deinem eigenen Rechner einrichten, oder einen vorhanden Server nutzen, auf den du per SSH oder anderem Remote-Zugriff zugreifst. Im Folgenden werden einige erprobte Lösungen für verschiedene Server-Betriebssysteme aufgeführt.

1.1  Linux

Die meisten Linux-Installationen bringen alles mit, was für die erfolgreiche Stud.IP-Entwicklung benötigt wird. Fast alle Produktiven Installationen von Stud.IP werden unter LINUX betrieben, so dass sich eine Linux-Umgebung eine gute Wahl für die Stud.IP-Entwicklung ist.

Distributionen wie Kubuntu 8.10 bringen leider von Hause aus nicht alles mit, was benötigt wird. Allerdings lassen sich Apache und MySQL hier sehr bequem installieren. Bei vorhandener Internetverbindung reicht der Konsolenbefehl

sudo apt-get install apache2

um den Apache Webserver zu installieren, der sich auch direkt startet.

Ähnlich simpel ist die Installation des Datenbankservers über die Konsole. Der hier zu verwendende Befehl lautet

sudo apt-get install mysql-server-5.0

Nicht die aktuelle php Version vergessen, auch die ist nicht immer installiert. Weiterhin benötigt man die Pakete für die Kommunikation von php und mysql

apt-get install php5 apt-get install php5-mysql

TODO

1.2  Windows

Auch unter Windows ist Stud.IP-Entwicklung möglich, an einigen wenigen Stellen gibt es Einschränkungen, aber in vielen Fällen spielt das keine Rolle. (Am besten vorher nachfragen! Wo? Richtig, im Developer-Board...)

Eine einfache und erfolgreiche erprobte Möglichkeit bietet das XAMPP-Paket. Mit Windows-typischer Installationsroutinen landen Webserver, PHP-Interpreter und MySQL-Datenbanksystem auf deinem Rechner. Nach der Installation unbedingt die Sicherheitshinweise beachten!

TODO

1.3  Mac OS

TODO

1.4  Andere Betriebssysteme

TODO

2.  Aktuelle Version besorgen

Die Stud.IP-Entwickler verwenden SVN für Versionsverwaltung, alle offiziellen Versionen sind anonym und öffentlich lesbar. Einen einfachen Einblick bietet die TRAC-Umgebung unter http://develop.studip.de/trac

Wichtig: Es gibt immer genau EINE Stud.IP-Version, an der aktiv entwickelt wird. Die liegt im SVN-Repository unter "trunk": http://develop.studip.de/trac/browser/trunk. Alle 6 Monate wird aus dem dann aktuellen Trunk ein Release geschnürt. Alte Releases werden z.T. noch mit Bugfixes versorgt, ansonsten arbeiten alle Entwickler immer mit der Trunk-Version.

Lesen darf jeder: Mit deinem SVN-Client kannst du unter svn://develop.studip.de/studip den kompletten Code auschecken. Es gibt eine ganze Reiher verschiedener Branches, die zum Teil sehr speziell sind. Du brauchst vor allem folgende Infos:

SVN-Kommando zum Auschecken der aktuellen Entwickler-Version:

svn co svn://develop.studip.de/studip/trunk

(als Benutzernamen und Passwort für den lesenden Zugriff muss jeweils studip eingegeben werden)

Schreiben darf allerdings nicht jeder. Zwar freuen wir uns über jeden, der eigene Entwicklungen, Bugfixes und Verbesserungen zu Stud.IP beitragen möchte, aber ohne sorgfältige Qualitätssicherung sollte natürlich kein Code in die aktuelle Version gelangen. Deshalb dürfen nur ausgewählte Entwickler Code in das Repository einchecken. Solange du noch nicht dazu gehörst, führt dein Weg über das Developer-Board.

3.  Installation und Konfiguration

Alle wichtigen Hinweise zur Stud.IP-Installation sind in der Installationsanleitung? aufgeführt. Da du keine Release-Version installierst, sondern eine SVN-Version, musst du folgende Unterschiede beachten:

  • TODO..

4.  Entwicklungsumgebung

4.1  Einfacher Texteditor

Minimalanforderung ist ein einfacher Texteditor, z.B. vi oder nano.

4.2  Erweiterter Texteditor

Erweiterte Texteditoren wie z.B. Kate bieten wesentlich mehr Komfort als vi oder nano, da sie Syntaxhervorhebung, geteilte Ansichten (mehrere Dateien in einem Fenster) und automatische Texteinfügung besitzen.

4.3  ECLIPSE

Bei Eclipse gibt es leider ein paar Probleme mit den Plugins, je nachdem welche Eclipse Version du verwenden willst solltest du auch verschiedene Plugins nehmen.

Für Eclipse 3.2

1. Direkter Download eines PHP fähigen Eclipse

Diese Variante ist die schnellste. Du musst dir einfach die All in one Version von der Webseite der Entwickler herunter laden, entpacken und dann reicht es Eclipse zu starten. Die Webseite findest du hier: http://www.eclipse.org/pdt/ Wenn du aber Eclipse auch für andere Programmieraufgaben verwendest und bereits ein eingerichtetes Eclipse hast solltest du noch ein wenig weiter lesen.

2. Einbinden des PDT über den automatischen Updater

Wenn du schon ein laufendes Eclipse benutzt und nicht mit zwei verschiedenen Eclipse Umgebungen arbeiten möchtest kannst du dein Eclipse auch über den automatischen Updater PHP fähig machen. Dafür wählst du im Programm "Help" --> "Software Updates" --> "Find and Install" aus und lässt Eclipse nach neuen Features suchen.

In dem nun auftauchenden Fenster musst du ihm mindestens eine neue Remote Site angeben, wie in der Abbildung gezeigt ist. Der Mirror lautet für das PDT "http://download.eclipse.org/tools/pdt/updates". Außerdem wirst du noch die Update Site " http://download.eclipse.org/webtools/updates/" brauchen, weil das PDT das WST unbedingt braucht und es nicht in den bereits enthaltenen Seiten gefunden werden kann.

Nachdem du beide neuen Remote Seiten angelegt hast musst du noch eben alle anhaken und kannst mit einem Klick auf "Finish" zum nächsten Schritt kommen.

Wenn du in diesem Fenster das PDT auswählst wird dir oben am Rand angezeigt, wovon das gewünschte Plugin abhängt. Nun kannst du dich entweder durch die Verzeichnisstruktur klicken auf der Suche nach den passenden Plugins, aber eigentlich sollte auch ein Klick auf "Select Required" genügen.

Wenn alle Abhängigkeiten gelöst sind kann es mit einem Klick auf "Next" gelangst du zu dem nächsten Schritt. Hier musst du nur den Lizenzbedingungen zustimmen. Wenn alles glatt gegangen ist kannst dir über "Help-->Software Updated --> Manage Configuration" deine aktuelle Konfiguration anzeigen lassen.

Es sollte in etwa so aussehen:

Wenn das alles geklappt hat kannst du mit deinem Eclipse nun auch PHP Code bearbeiten.

Ein weiteres sinnvolles Plugin für Eclipse ist Subclipse. Damit kannst du dir über Eclipse direkt den Stud.IP Quellcode auschecken. Die Installation von Subclipse verläuft analog, allerdings verständlicherweise mit anderen Plugins und Abhängigkeiten.

3. Einbinden des PDT manuell

Falls du mit dem automatischen Updater aus irgendwelchen Gründen nicht arbeiten willst oder kannst musst du dir Plugins manuell downloaden und installieren. Die Abhängigkeiten werden sehr gut auf der Seite http://www.eclipse.org/pdt/downloads/ erklärt. Nachdem du dir alle benötigten Pakete geladen hast musst du sie nur entpacken und in die entsprechenden Ordner deines Eclipse kopieren.

Für Eclipse Ganymede 3.4

Leider funktioniert das PDT Plugin nicht so einfach mit Ganymede. Aber hier gibt es eine Alternative mit dem Plugin PHPEclipse.

Auch dabei funktioniert am besten das automatisch Update über Help --> Software Updates, allerdings brauchst du als Mirror Site http://update.phpeclipse.net/update/stable/1.2.x

Wenn es noch ungelöste Abhängigkeiten gibt wird Eclipse dir das noch sagen und dich auffordern diese zu lösen. Nach der Installation und einem Neustart von Eclipse kann es dann aber losgehen mit der PHP Programmierung.

Für die bequemere Stud.IP Entwicklung solltest du aber auch noch das SVN Plugin installieren. Damit kannst du dir direkt die aktuelle Version von Stud.IP in Eclipse laden.

Dafür musst du noch das SVN Plugin installieren. Auch hier geht das wieder am einfachsten über Help --> Software Updates noch die Mirror Seite http://subclipse.tigris.org/update_1.4.x hinzufügen und dann einfach nach "Subclipse" bzw. "SVN" suchen und "Subclipse", "SVNKit Library" und "SVNKit Client Adapter" installieren lassen.

WICHTIG:

Falls du Fehlermeldungen beim Installieren erhälst schau unbedingt nach, ob die anderen Seiten unter "Manage Sites" aktiviert sind. Du brauchst zwar nicht alle, aber einige sind unerlässlich zum Installieren der Plugins.

Stud.IP in Eclipse laden

Nachdem du alles erfolgreich installiert hast kann es nun wirklich losgehen. Wenn du noch keine Stud.IP Version geladen hast kannst du sie dir direkt über Eclipse und SVN importieren.

Dafür klickst du einfach File -> New -> Project... und wählst unter SVN "Projects from SVN". Nach einem Klick auf Next wirst du aufgefordert die richtige URL anzugeben. Wie du oben schon gesehen hast lautet sie svn://develop.studip.de/studip/trunk

  • TODO..

Wenn du dann Eclipse fertig eingerichtet hast erwartet dich eine sehr komfortable Benutzeroberfläche die fast keine Wünsche offen lässt.

5.  Änderungen einchecken

Schreiben darf wie gesagt nicht jeder im SVN. Zwar freuen wir uns über jeden, der eigene Entwicklungen, Bugfixes und Verbesserungen zu Stud.IP beitragen möchte, aber ohne sorgfältige Qualitätssicherung sollte natürlich kein Code in die aktuelle Version gelangen. Deshalb dürfen nur ausgewählte Entwickler Code in das Repository einchecken. Solange du noch nicht dazu gehörst, führt dein Weg über das Developer-Board.

Nächste Seite HowToFiles

Letzte Änderung am 13.06.2016 15:58 Uhr von strohm. Abschnitt über erweiterte Texteditoren eingefügt